
FFExplorer 
TUTORIAL 

 

This tutorial provides an overview of FFExplorer v13.1, hereafter FFE. With this information you will learn 

how to use the application, but for better results a basic idea of fractal geometry would be needed. 

 

 

 

 

« Being a language, mathematics may be used not only to inform but also, among 

other things, to seduce... » 

Benoît Mandelbrot, creator of the Theory of Fractals 

 

fractalfun.es/en. 

 

 

 

http://www.fractalfun.es/en
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EXPLORE A FRACTAL 

Open a new canvas from “File” menu or press “Control + N”. If you want to load a specific type of fractal, 

hold the pointer on “New canvas of type” and choose the type of fractal in the secondary menu displayed. 

To explore a fractal, you can do the following actions:  

• ZOOM IN 

With the left mouse button, click on a point over the image and, still holding, slide the mouse in 

order to create a selection area. Release the button so you zoom in the selected area. See more 

zoom options in the “Exploring guide”, which is available in the menu “Help” of FFE. 

 

• ZOOM OUT 

With the right mouse button, click on a point over the image and, still holding, slide the mouse in 

order to create a selection area. Release the button so you zoom out the selected area. If you do 

the previous action pressing “Alt” key it will zoom centered in the canvas. 

 

• CENTERING 

There are three options: 

1. Double-click on a point of the image to centre it. 

2. Click on a point of the image while the “F” key is pressed. 
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3. With the middle mouse button, click on a point over the image and, still holding, slide the 

mouse in order to create a selection area. Release the button so you centre the central 

point of the selected area on the canvas. 

 

• SCROLLING 

There are two options: 

1. Press and hold the “Shift” key while you click with the left mouse button on a point over 

the image in order to fix an origin point. Without releasing both buttons, slide the pointer 

to the destination point. Release the mouse button to confirm the scroll from the origin 

point to the destination point. 

 

2. Press and hold the “Control” key while you click with the left mouse button on a point over 

the image to “catch it”. Without releasing both buttons, slide the pointer to drag the image 

to a new position. Release the mouse button to confirm the image scroll to the new 

position. 
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• ROTATION 

* Rotation is not available for the special fractals Bifurcation and IFS. 

There are two options: 

1. Press and hold the “Shift” key while you click with the right mouse button on a point over 

the image in order to fix the rotation centre. Without releasing both buttons, slide the 

pointer horizontally to rotate the image. Release the mouse button to confirm the image 

rotation. 

 

2. Press and hold the “Control” key while you click with the right mouse button on any point 

over the image. Without releasing both buttons, slide the pointer horizontally to rotate the 

image around its central point. Release the mouse button to confirm the image rotation. 
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This rotation type can be performed more accurately in the form “Edit” that will be seen 

later. 

• RESIZING 

Resize the window so the canvas adapts itself to the window. While you are performing this 

operation, the canvas size is shown in the window frame. 

 

You can also resize a canvas with the size and aspect-ratio adjustment options, available in the 

“Window” menu. 

• GET A SATELLITE VIEW 

Click on “satellite view” in “Edit” menu or press “Control + Up” in order to zoom out and watch the 

full fractal. With this operation the central point of the origin image will remain centred on the 

canvas. 

 

• GET A MAIN VIEW 

Click on “Main view” in “Edit” menu or press “Control + Space” in order to fit a full view of the 

fractal in the canvas. With this operation the reference of the central point of the origin image will 

be lost. 
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All actions that require to perform a selection with your mouse, when they are finished, will set the centre 

point of the selected area on the canvas centre. These actions can be cancelled pressing “Escape” before 

releasing the left mouse button. 

Learn more… 

In order to show the images faster, it is recommendable to use a small canvas when you are exploring and, 

once you get the wished aspect, resize it to generate the final image. 

To avoid unwanted image frame changes caused by resizing, you must keep in mind the aspect ratio wanted 

for the final image from the beginning. For example: if you want to generate an 1,600 x 1,000 px image it is 

recommendable to work with a small canvas with proportional dimensions. The aspect ratio you want is 

1,600/1,000 = 1.6, thus any canvas with that aspect ratio will allow to avoid the problem, i.e. 320 x 200 px. 

When you open a new canvas without specifying the type of fractal, it loads the last selected type.  

 

CHANGE THE TYPE OF FRACTAL 

Open the tool “Parameters” from the “View” menu or press “Control + Alt + P”. This tool has one tab page 

per type of fractal (zone 1 in the image) with their parameters (zone 2 in the image) and an area of common 

parameters to all the fractals (zone 3 in the image). Select the different tab pages in order to change the 

type of fractal. 

FFE 13.1 version includes these fractals: Mandelbrot, Phoenix, Burning Ship, Lambda, Magnet, Spider, 

Manowar, Nova, IRF (Newton, Halley, Secant, Householder, Schröder, Steffensen, Laguerre, Muller, 

Parhalley, Whittaker and Chebyshev), Fatou, Collatz, Mandelbox 2D, Lyapunov, Bifurcation, IFS, 

Buddhabrot, Attractor and Linear. These main functions allow to create up to 224 different types of fractal. 

There is also the possibility of creating custom formulas, as it will be seen later. 

Mandelbox 2D, Lyapunov, Bifurcation, IFS, Buddhabrot, Attractor and Linear are special fractals and some 

functions that are described in this tutorial do not apply to these fractals. 
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If there are several canvases opened, this tool shows the parameters of the “Active canvas”, which is the 

last canvas that has been activated. This also applies to other tools forms that will be seen later. The “Active 

canvas” is identified with an arrow-shaped icon.  

 

 

 

 

1 

2 

3 



 

 

10 FFExplorer v13.1 - Tutorial Translated to English by Vanessa JH 

10 

 

Learn more… 

Every canvas has an independent history of changes for each type of fractal, so that when switching to 

another type, it does not lose the history of changes of any of them. You can access this history of changes 

in “Edit” menu by clicking on “Undo” and “Redo”, or press “Control + Z” and “Control + Y” respectively. 

When exploring the fractal, a change of colour may happen in the icon of “Active canvas”, turning into 

orange. This means that you have exceeded the computer's processing capabilities. 

 

MODIFY PARAMETERS OF A FUNCTION 

Every fractal is generated from an algorithm. This algorithm has certain parameters that can be modified. 

Open the tool “Parameters” from the “View” menu or press “Control + Alt + P” and change the values in 

order to create variations in the original fractal. Press “Enter” key in the parameter field to apply the 

changes. 

 

The common parameters to all fractals are (zone 1 of the image): 

• NUMBER OF ITERATIONS (positive integer) 

1 
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Indicates how many times the function will be recalculated. A high value gives the fractal more 

“depth” to do a zoom in, but it will slow the calculation. The iterations should be increased gradually 

only when necessary. 

• CENTRAL COORDINATES (complex number) 

This parameter allows to centre a determinate point of the fractal within the canvas by indicating 

its coordinates.  When exploring the fractal, this value changes with the coordinates of the point of 

the fractal that corresponds with the centre of the canvas. 

• ZOOM (positive decimal number) 

This parameter allows positive or negative zooming on the central coordinates. When exploring the 

fractal, this value changes with the zoom level. 

To locate an area of the fractal in FFE, the "Central coordinates" and "Zoom" parameters must be 

used together. Also, it may be necessary to adjust the "Number of iterations". The zoom level can 

be provided in scientific notation, and in that case, to enter it in the “parameters” form, it is 

necessary to transform it as follows: 

Scientific notation E notation Value 

123.456789 x 104 

123.456789 x 10-4 

123.456789E4 

123.456789E-4 

1234567.89 

0.0123456789 

 

For example, the following parameters correspond to the location of an elephant, from the Valley 

of the Elephants, from the Mandelbrot set: 

Central coordinates: 0.276507227815727, -0.00652125825352444 i 

Zoom: x 12836.3610205248 

The specific parameters of the fractal type are: 

• EXPONENT OF Z (decimal number) 

* This parameter cannot be modified for the special fractals. 

It is the exponent of the variable “Z” and it allows to create mutations in the original fractal. 

• JULIA'S CONSTANT (complex number) 

When you activate this parameter, the variable “C” is changed to be constant with the set value 

and the fractal is drawn through “Julia’s method”. 

When this is deactivated, the value is not used, and the fractal recovers the previous status in the 

activation through “Mandelbrot’s method”. In this case, when exploring the fractal, the default 

value for the “C” constant changes corresponding to the coordinates of image’s central point. 
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• DISTORTION CONSTANT (complex number) 

This constant distorts the fractal aspect. If the value is zero, it has no effect on it. 

• RELAXATION CONSTANT (complex number) 

This constant adjusts the fractal complexity. If the value is one, it has no effect on it. 

• INITIAL VALUE OF Z (complex number) 

It is the value of the variable “Z” used to start iterating the function and it allows to create mutations 

in the original fractal. 

• INITIAL VALUE OF X (decimal number) 

It is the value of the variable “X” used to start iterating the function and it allows to create 

mutations in the original fractal. 

• BAILOUT / TOLERANCE (positive decimal) 

Its value sets a critical-escape condition that, if met, interrupts the iteration process. 

• SCALE / RADIUS * / LAYER Z (decimal number) 

These parameters change the size and appearance of the multifractals. 

• LYAPUNOV’S SEQUENCE (binary sequence) 

It is a sequence of values 0 and 1 that determines the value used to iterate the function. 

• PLANE 

This option applies transformations that affect the variable that traverse the plane and allows you 

to create variants of the fractal. 

Learn more… 

Complex numbers have a real part and an imaginary part, and they are represented as “Z = (a + b i)”, where 

“a” is a real number and “b” is an imaginary number, multiple of the imaginary unit “i”. The numbers “a” 

and “b” can be positive or negative decimals and the imaginary unit “i” is a constant that equals to square 

root of -1.  

To optimize the calculation process it is recommendable to increase the number of iterations only when 

necessary. For example, you may increase it gradually when you zoom in, or decrease it when zooming out. 

When modifying the parameters of the fractal, a change of colour may happen in the icon of “Active 

canvas”, turning into blue. This means that there are parameters still pending to apply. 
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CREATE CUSTOM FORMULAS 

To add new formulas, the syntax of the Visual Basic programming language must be used, of which the 

application recognizes the Math class and the Complex data structure.  

FFE allows you to create formulas that will take advantage of all the features of the fractal and colouring 

algorithms available in the application. To do this, open the formula editor from the “View” menu or by 

pressing “Alt + O”. 

 

This tool allows you to customize the formula by following these steps:  

1. DEFINITION OF VARIABLES 

In this step, all the variables that will be used in the formula must be defined, which can be of the 

following types: 

https://docs.microsoft.com/en-us/dotnet/api/system.math?view=netframework-4.7.2
https://docs.microsoft.com/en-us/dotnet/api/system.numerics.complex?view=netframework-4.7.2
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• Iteration: variable to iterate. This is the variable whose value will be used to colour the 

analysed pixel after its iteration process. In the parameters form, its initial value can be 

modified. (Maximum: 1 variable) 

• Pixel: variable to traverse the plane. This is the variable that the algorithm will use to store 

the coordinates of the complex plane that it is going to analyse at all times, and that 

correspond to the pixel to be coloured. (Maximum: 1 variable) 

• Value: auxiliary variable. This is a variable that can be used for different purposes. For 

example, as a constant value or to store the result of an operation whose value you want 

to use multiple times later. (Maximum: not established) 

2. PREVIOUS OPERATIONS (optional) 

In this step you can define operations before to the iteration process. For example: 

• Calculation of mirror plane “C + = 1 / C”, where “C” is the variable of type “pixel”. 

• Inverse plane calculation “C = 1 / C”, where “C” is the “pixel” type variable. 

Although you can force the inverse plane in this way, it is a good idea not to do it and let 

the application try to do it itself when the “Invert” option is activated in the parameters 

form. 

• Julia mode “Z = P”, where “Z” is the variable of type “iteration” and “P” is the variable of 

type “pixel”. Although “Julia mode” can be forced in this way, it is a good idea not to do it 

and let the application try to do it itself when the “Julia’s constant” is activated in the 

parameters form. 

At this point it is also possible to initialize variables of type “Value” with the values of other variables 

whose type can only be used once. For example: “V = C”, where “V” is a variable of type “Value” 

and “C” is the variable of type “pixel”. 

3. BAILOUT CONDITIONS 

In this step, the conditions that, if produced, will make the iteration process end before the 

iterations entered in the parameter form have been consumed, will be defined. Conditions can be 

of the following types: 

• Bailout: it will be given when the absolute value of the chosen variable exceeds the value 

of the bailout entered. 

• Tolerance: will be given when the absolute value of the chosen variable is less than or equal 

to the tolerance value entered. 

In the parameters form, the values of “Bailout” and “Tolerance” can be modified. 

4. ITERATION LOOP OPERATIONS 

In this step, the operations of the iteration loop will be defined, that is, the operations that 

correspond to the iterative function of the fractal. 
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5. FOLLOWING OPERATIONS (optional) 

In this step you can define operations after to the iteration process. 

6. COMMENTS (optional) 

In this section you can add any useful information related to the formula or its author. 

To finish, enter the name with which you want to save the formula, a class name for its grouping (optional) 

and then press one of the following buttons (depending on the desired action): 

• Apply, to save and change the active canvas formula to the new one. 

• Open, to save and open a new canvas that uses the formula. 

• Save, to save the formula. 

If the formula is compiled correctly, it will become available along with the rest of the algorithms built into 

the application. In the event of compilation errors, an informational message will appear and the errors will 

need to be fixed before the formula can be used. 

When the active canvas displays a fractal calculated with a formula of the editor, the editor will offer the 

possibility to add a representative image of the fractal to the formula. To do this, explore the fractal, check 

the “Current formula” box and press the “Include example” or “Update example” button. Then press the 

“Save” button to overwrite the formula.  

To open a canvas with the example formula, click on its preview. 

Important: for performance reasons it is not recommended to declare variables of type "Complex" if only 

its real component is going to be used. Similarly, it is not recommended to calculate known values: 

Not recommended Recommended 

V = New Complex(2, 0) 

PI = 2 * Math.Asin(1) 

PHI = (Math.Sqrt(5) + 1) / 2 

V = 2 

PI = Math.PI 

PHI = 1.6180339887498949 

 

Sample formulas can be loaded into the formula editor from the file menu, by positioning the mouse cursor 

on "Open example formula" and choosing the desired formula example. 
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CHANGE THE COLOURING METHOD 

* The special fractals use specific colouring methods that cannot be changed. 

In order to draw a fractal, it is necessary to define a colouring method. FFE uses the “Escape time” algorithm 

by default. To use another method, click on “Settings” menu and hold the pointer on “Colouring method by 

default”. Click on the method you wish to use by default in the displayed submenu. 

FFE has the following colouring methods: 

• ESCAPE TIME: 

It colours the image according to the number of iterations reached during the calculation process. 

 

This colouring method allows you to use shapes and supershapes to define the escape perimeter: 

 

• ESCAPE ANGLE: 

It colours the image according to the angle between the variable used to iterate and the horizontal 

axis during the calculation process. It allows to choose from different reference angles. It also allows 

to represent the phase portrait of the fractal, which will not be affected by the configured escape 

radius and will provide better results in fractals with few iterations. 
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• DISTANCE TO A POINT: 

It colours the image according to the closest distance to a point reached by a variable used during 

the calculation process. It allows to choose from different geometric shapes and customized shapes 

to represent the distance. 

 

All the colouring methods described above allow the possibility of smooth the sudden changes of colour, 

except in the special case of colouration by escape time with shape or supershape. To activate this option 

by default, click on the menu "Settings" and then on "Activate smoothed colouring by default". 

 
Smooth Escape Time colouring. 

Escape Time colouring. 
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All the colouring methods admit an illumination effect based on slope. To activate this option by default, 

click on the menu "Settings" and then on "Activate illuminated colouring by default". 

 
Illuminated Escape Time colouring. 

Smooth Escape Time colouring. 

 

* Fractals that use the bailout offer better results in smoothing and illumination with a high bailout. 

You can change the colouring method for a specific canvas in the “Colouring” tag in the form “Edit”, which 

opens from the “View” menu, or press “Ctrl + Alt + E”, where you will be able to use some advanced settings: 

• To obtain a preview of the coloring of the “Active Canvas” and to be able to modify its parameters, 

check the “Current method” box. 

• Use the lighting controls to change the color, angle and height of the spotlight. This last feature will 

make the shadows sharper and longer or softer and shorter. 

“Juliter” colouring will only be available when the active canvas has the “Juliter Transformation” applied, 

this colouring mode will make only the iterations consumed during the transformation calculation be used 

to colouring, not the previous ones. 
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APPLY AND MANAGE PALETTES 

* Each fractal type has its own predetermined palette associated, except for the special fractals Lyapunov, 

Bifurcation, IFS, Attractor and Mandelbox 2D in its X-Ray version. To change their colour, use “Colour in” or 

“last iteration in...” (it will be seen in “Special options”). 

To use a different palette, click on “Edit” menu and hold the pointer on “Apply palette”. Click on the type 

of palette you wish to apply in the displayed submenu, and finally on the palette. This option is also available 

in the “Palettes” tag in the form “Edit”, which opens from the “View” menu, or press “Ctrl + Alt + E”, where 

you will be able to use some advanced settings: 

• Check the “Current palette” box to get a preview of the “Active canvas” palette or to view its 

number of colours. 

• To scroll the colours of the palette, you can click with the left mouse button on preview and slide 

the pointer. You can see the scrolling value below the preview. Then click on “Apply”. 
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Special options: 

• LAST ITERATION IN... / COLOUR IN... 

This option uses a determined colour to draw during the calculation of the last iteration. To active 

it, check the corresponding box or select a colour in the selection area. If the type of palette is 

“External”, and it has at least 256 colours, it will habilitate the possibility of using the first colour 

for the last iteration, eliminating it form the palette. 

This colour is to be employed in the special fractals Bifurcation, Lyapunov and Attractor. 

• LAST ITERATION OVER ORBIT TRAP 

This option draws the area that corresponds to the last iteration of its formula over the orbit trap. 

To manage palettes, you have the following functions: 

• IMPORT PALETTES 

Predetermined palettes are built in the application, but there is a possibility to add new palettes. 

To do this, click on “Import palettes” in “File” menu. In the dialog box that opens, select one or 

more palette files with extension F2C (external palette), F2CC (customized palette) o F2ZC (palettes 

package), and click on “Open”. 

The new palettes are copied in the palettes folder of the application. 

 

 

1 
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• DELETE A PALETTE 

Click on “File” menu and hold the pointer on “Delete palette”. Click on the type of palette you want 

to delete in the displayed submenu, and finally on the palette. 

The built-in palettes are shown up with an asterisk and they cannot be deleted. These are: 

1. Random B&W: its grey hues change randomly every time it is applied. 

2. Random RGB: its colours change randomly every time it is applied. 

3. Random R: its red hues change randomly every time it is applied. 

4. Random G: its green hues change randomly every time it is applied. 

5. Random B: its blue hues change randomly every time it is applied. 

6. Rainbow: decomposition of white colour in the rainbow colours.  

7. Striped: predetermined palette in these fractal types: Magnet, Spider, Manowar, Newton, 

Halley, Secant, Householder, Schröder, Steffensen, Laguerre, Whittaker, Fatou, Collatz, 

random Julias and Mandelbox 2D. 

8. Striped-Legacy: previous version of the palette Striped. 

9. Continuous: predetermined palette in these fractal types:  Mandelbrot, Phoenix, Burning 

Ship, Lambda and Nova. 

10. Continuous-Legacy: previous version of the palette Continuous. 

11. Editor: temporary palette from the “Customized palettes editor”. 

12. B.Default: predetermined palette associated with the type of fractal, really is “Striped” or 

“Continuous”. 

The options of palettes management are also available in the form “File”, which opens from “View” menu, 

or pressing “Ctrl + Alt + F”. 
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Learn more… 

Palette files can also been imported by dragging and dropping them in the FFE working area. 

In most of palettes the first colour is black. The reason behind this is that when calculating a fractal with a 

number of iterations multiple of the number of colours of the palette, the points corresponding to the latest 

iteration of the function will always be drawn in black. 
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CREATING CUSTOMIZED PALETTES 

Open the “Customized palettes editor” from the “View” menu or press “Alt + I”. 

 

This tool is divided into two parts: 

• COLOUR EDITOR (zone 1 of the image) 

It allows to design a gradient of 1024 colours from a sample of 16 main colours maximum, and 2 

minimum. A predefined sample can be loaded from the menu “Theme”, or it can be customized 

clicking on its colours in order to change them. 

In order to add more colours to a sample click on the gradient over the positions that you want to 

add them. Double click over the marks that indicate the positions of the colours when you want to 

eliminate them (above the gradient). These marks can also change the position of colours- to do so 

click with the left button on them, move them and release the button in order to update the 

gradient. 

• PALETTE GENERATOR 

It allows to create a 1024 colour palette (maximum) from the gradient designed before. In order to 

do this chose the number of colours you want for the palette, write a name and click on the button 

“Save”. 

The option “Try as…” is useful in order to preview a palette before saving it, but as a temporary 

palette, it must be saved in order to make sure the image keeps its aspect. 

 

1 

2 
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APPLY AND MANAGE ORBIT TRAPS AND PATTERNS 

* Orbit traps are not available for the special fractals. 

The “Orbit trap” is a special colouring method based on a pattern to be adapted to the fractal. FFE 13.1 

version includes 78 built-in shapes, the option to create customized shapes and an image’s pattern function. 

With all this the next types of orbit traps can be applied: 

• NONE: it is the default type and it is used to suppress the orbit trap. The fractal is drawn with the 

colouring method by default applied to the canvas. 

• SHAPE: it uses a built-in shape to draw the fractal. 

• SUPERFORMULA: uses a customized shape using a formula to draw the fractal. 

• PATTERN: this trap uses an image file as a pattern and it is the only one that is not based on palettes. 

• MULTIPLE: it uses several built-in shapes, customized and/or patterns simultaneously to draw the 

fractal. 

To use a simple orbit trap, click on “Edit” menu and hold the pointer on “Apply orbit trap”. Click in the type 

of pattern you wish to apply in the displayed submenu. This option is also available in the “Orbit trap” tag 

in the form “Edit”, which opens from the “View” menu, or press “Ctrl + Alt + E”, where you would also be 

able to choose other types of orbit trap and to modify its properties (zone 1 in the image): 

• To get a preview of the “Active canvas” orbit trap, you can check the “Current trap” box. 

• To scroll the orbit trap, you can click with the left mouse button on the preview and slide the 

pointer. You can see the scrolling value below the preview. Then click on “Apply” (“Add” or 

“Replace” if the orbit trap is “Multiple”). 

• To change the rest of orbit trap properties, you can change their values with the adjusting controls 

and then click on “Apply” (“Add” or “Replace” if the orbit trap is “Multiple”). 

An FFE feature worth talking about is that FFE allows you to configure the adjusting controls in order to 

make a more accurate adjust of the parameter. You can do this by using an extra control that allows you to 

select the specific decimal position that you wish to modify (zone 2 of the image). 
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If the selected orbit trap is “Multiple”, the objects will be added or replaced in the “Multiple trap” editor, 

where they can be organized and applied as a whole. 

1 

2 
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There are differences between the “Simple” orbit trap (1) and the “Multiple” orbit trap formed by only one 

pattern (2) if the opacity is not the maximum. The first melts the overlapping and the second lets it be seen. 

Additionally, there is the possibility of splitting the palette’s colours for the multiple orbit trap (3). 

 

_2_  _1_  _3_  
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To design customized shapes, read the section “Create customized shapes”. 

To manage patterns, you have the following functions: 

• IMPORT PATTERNS 

There are predetermined patterns built in the application, but there is a possibility to add new 

patterns. To do this, click on “Import patterns” in “File” menu. In the dialog box that opens, select 

one or more image files with extension PNG, WEBP, SVG, GIF, BMP o JPG, and click on “Open”. 

The new patterns are copied in the patterns folder of the application. 

• DELETE PATTERNS 

Click on “File” menu and hold the pointer on “Delete pattern”. Click on the pattern you want to 

delete in the displayed submenu. 

The built-in patterns are shown up with an asterisk and they cannot be deleted. 

The options of patterns management are also available in the form “File”, which opens from “View” menu, 

or pressing “Ctrl + Alt + F”. 

 

Learn more… 

To create customized orbit traps you can draw a PNG image with transparent areas and import it as a 

pattern. When using this pattern, the fractal will be drawn with its image, and the transparent areas will let 

see what is underneath. 
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The drawing process adapts the pattern to the fractal’s shape folding and stretching it, what can make the 

result to be distorted if the pattern has low quality. In order to avoid this you should use patterns with big 

dimensions, that will allow you to zooming in even deeper without losing the quality all too soon. 

Patten files can also been imported by dragging and dropping them in the FFE working area. 

 

ROTATE A FRACTAL 

* Rotation is not available for the special fractals Bifurcation and IFS. 

To adjust the fractal rotation, click on “Edit” menu and hold the pointer on “Rotate”. Click the rotation that 

you wish to apply in the displayed submenu. 

 

This option is also available in the “Orbit trap” tag in the form “Edit”, which opens from the “View” menu, 

or press “Ctrl + Alt + E”: 

• To see the “Active canvas” rotation you can check the “Current rotation” box. 

• To adjust the angle, you can click with the left mouse button on preview and slide the pointer. You 

can see the scrolling value below the preview. Then click on “Apply”. 

• To remove the canvas’ rotation, press the button “R” and then the button “Apply”. 

• For a more accurate adjusting of the angle, you can use the adjusting control and then click on 

“Apply rotation”. 
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CREATE CUSTOMIZED SHAPES 

* Customized shapes are not available for special fractals.  

FFE has a customized shapes editor based on “Super Formula” to create shapes that can be used in distance 

colouring and as an orbital trap. 

Open the superformula editor from the “View” menu or by pressing “Alt + F”. 
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The “Display Area” checkbox shows a shadow under the shape which can be useful for displaying annular 

shapes in the preview. 

The “Display recommended scale” checkbox shows a frame in which it is recommended to fit the shape 

before saving it. 

Adjust the parameters of the superformula to create the customized shape, enter a name and finally press 

the “Save” button. The customized shape will be available for use in distance-based colouring and as an 

orbit trap. 

To manage customized shapes, you have the following functions: 

• IMPORT SUPERFORMULAS 

Application has a built-in superformula, but there is a possibility to add new superformulas. To do 

this, click on “Import superformulas” in “File” menu. In the dialog box that opens, select one or 

more superformula files, with extension F2S or F2SZ, and click on “Open”. 
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The new superformulas are copied in the superformulas folder of the application. 

• DELETE SUPERFORMULAS 

Click on “File” menu and hold the pointer on “Delete superformula”. Click on the superformula you 

want to delete in the displayed submenu. 

The built-in superformulas are shown up with an asterisk and they cannot be deleted. 

The options of superformulas management are also available in the form “File”, which opens from “View” 

menu, or pressing “Ctrl + Alt + F”. 

 

Learn more… 

The superformula is a generalization in polar coordinates of the superelipse formula. Many examples can 

be found on the Internet that show the values of the parameters required to obtain known shapes. You can 

make “Superformula” work like “Superelipse” using the values A, B, M1 = M2 = 4 and N1 = N2 = N3. More 

information here. 

 

 

 

 

 

https://www.fractalfun.es/superformula.php?i=en
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USING THE ELEMENTS SELECTOR 

Some of the tools seen above have access to the “Element picker” for ease of use. From the "Element picker" 

you can choose palettes, themes, orbit traps, shapes, superformulas and formulas depending on the type 

of tool and the action being performed on it. Once the element is chosen in the selector, it will be set in the 

tool and could be used from it. 

It should be noted that the "Element picker" will display different subsets of the element type, depending 

on the tool's configuration at any given time. 

For example, to choose an orbit trap, open the “Edit” form, select the “Orbit trap” tab, and choose a subset 

of traps (shape, supershape, or pattern). Next, double-click on the orbit trap preview to bring up the 

selector. In the selector, enter a filter to find specific elements more easily and double click on the desired 

element. The element will be set in the tool and could be used from there. 
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Next it is how to open the “Element picker” for different types of elements: 

Element type Selector access 

Palette for base colouring Edit form, “Palette” tab: double click on the main palette preview. 

Orbit trap colouring palette Edit form, “Orbit trap” tab: double click the orbital trap palette 

preview. 

Shape for the perimeter of the 

scape radius 

Edit form, “Colouring” tab, “Escape” mode: double click on the 

colouration preview. 

Shape for base colouration Edit form, “Colouring” tab, “Distance” mode: double click on the 

colouration preview. 

Orbit trap Edit form, “Orbit trap” tab: double click on the orbit trap preview. 

Superformula Superformula editor: double click on the superformula preview. 

Colour theme Customized palettes editor: double click on the palette preview. 

Formula Formula editor: double click the preview of the formula example. 

 

SETTING OPTIONS 

Open the form “Options” from the “View” menu or press “Control + Alt + O”. This form has an area of 

options that can only be changed when the “Active canvas” is not in calculating process (zone 1 on the 

image) and another with options that can be changed at any time (zone 2 on the image). 

 

1 

2 
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The available options out of the calculation process are: 

• ACTIVATE ANTI-ALIASING FILTER WITH GRILLE… 

* Anti-aliasing filtering is not available for the special fractals IFS, Buddhabrot and Attractor. 

“Anti-aliasing” is a method that allows obtaining higher quality images, closest to the fractal, using 

additional colouring operations. This drawing method increases the process time, so it is 

recommended to keep it disabled and use it just for final images that are going to be saved 

afterwards. To active it, check the corresponding box or select the grille size in the combo box. 

Anti-aliasing Description 

1x1 Low quality and high speed (without anti-aliasing) 

2x2 Medium quality and high speed 

3x3 High quality and medium speed 

4x4 Very high quality and low speed 

 

You can apply the “Anti-aliasing filter” punctually to an image without enabling the option. To do 

this, open the form “Anti-aliasing filter” from the “View” menu or press “Control + Alt + A”. Select 

the grille size and click on “Apply”.  

The available options at all times are: 

• ACTIVATE FAST SCROLLING 

* Fast scrolling is not available for the special fractals. 

When scrolling the fractal with the mouse, the previous image is used in order to not calculate the 

new image fully. Before saving the image after a fast scrolling it is recommended to recalculate it 

by pressing F5 or applying an “anti-aliasing filter". The canvas with this option activated is identified 

with an arrow-shaped icon preceded by two white lines. 

• ACTIVATE MOUSE FREE SCROLLING 

This option makes that, when doing any movement with the mouse upon the image, the operation 

is not compromised if the pointer gets the screen’s limits. 

• SHOW FRAMING GUIDES – HALVES 

This option shows up some guidelines dividing the width and length of the canvas in halves in order 

to improve de framing when making any operation with the mouse over the image. 

• SHOW FRAMING GUIDES – THIRDS 

This option shows up some guidelines dividing the width and length in thirds in order to improve 

the framing when making any operation with the mouse over the image. 
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• SHOW FRAMING GUIDES - GOLDEN RATIO (L, R) 

This option shows up some guidelines representing the golden ratio in order to improve the framing 

when making any operation with the mouse over the image. 

• SHOW FRAMING GUIDES - MAXIMUM CIRCLE 

This option shows up a guideline representing the maximum circle in order to improve the framing 

when making any operation with the mouse over the image. 

• SHOW FRAMING GUIDES - THIRD CIRCLE 

This option shows up a guideline representing the circle equal in size to one third in order to 

improve the framing when making any operation with the mouse over the image. 

• SAVE IMAGE CHANGES AUTOMATICALLY 

This option saves automatically the image of the fractal every time it changes. The images are saved 

in “PNG” format in the images folder of the application, inside a canvas subfolder on which the 

option is enabled. You can open the images folder of the active canvas in “File” menu by clicking on 

“Open images folder of the canvas” or press “Control + Shift + O” (this folder is created when the 

first image is saved). 

• ACTIVATE PARALLEL COMPUTATION 

This option takes full advantage of the processor's capabilities to calculate images more quickly. 

• ACTIVATE IMAGE REFRESHING (Legacy) 

This option refreshes progressively the image while it is calculating. It’s recommended to have it 

disabled because it slows the calculation process. This option is retained for its usefulness in some 

cases, but prevents multiple threads and parallel computation from being used to compute images 

more quickly. 

Learn more… 

The images that hold a high number of different colours in small areas improve their quality if you apply 

the “anti-aliasing filter" with a big grille size. However, for images with big areas of the same colour, 

applying a small grille size would be enough. It is recommended to experiment with this in order to learn 

how to choose the optimal grille depending on the type of image, because in some cases a big grille size 

slows the calculation process and it provides a little addition to what a lower grid would. 

The option “save image changes automatically” can be used combined with a task in order to get images, 

like movie frames, for building a video or animation using an external application. 

The option “Activate fast scrolling” can be activated by default for all canvas from the “Settings” menu. 

Before saving the image after a fast scrolling it is recommended to recalculate it by pressing F5 or applying 

an anti-aliasing filter. 
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WORKING WITH PARAMETERS 

An important feature of FFE is that it allows taking a snapshot of all the parameters and configurations 

needed to draw a fractal at any time. This information is registered in a file inside the application that allows 

recovering the image anytime.   

During its running, FFE keeps in memory a list of the thirty last parameters, corresponding to closed 

canvases. This characteristic allows recovering previously discarded fractals if its parameters has not been 

overwritten already. 

To administrate parameters, you have these functions: 

• REGISTER PARAMETERS 

Click on “Register parameters” in “File” menu or press “Control + R”. In the form that opens write 

a name for the parameters and a comment (optional). Then click on “Register”. 

• LOAD PARAMETERS 

Click on “File” menu and hold the pointer on “Load parameters”. In submenu displayed, click on 

the parameters you want to load. 

• RENAME PARAMETERS 

Click on “File” menu and hold the pointer on “Rename parameters”. Click on the parameters you 

want to rename in the displayed submenu. Write a new name and click on “Rename” in the form 

that opens. 

• DELETE PARAMETERS 

Click on “File” menu and hold the pointer on “Delete parameters”. Click on the parameters you 

want to delete in the displayed submenu. 

• RECOVER PARAMETERS 

Click on “File” menu and hold the pointer on “Recover parameters”. In submenu displayed, click on 

the parameters you want to recover. 

In the displayed submenus with the name of the registered parameters, if you hold the pointer over the 

parameter, a label is displayed with the comment that was written when registered.  

All described options can also be found in the form “File” that opens from the “View” menu or pressing 

“Control + Alt + F”. 
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Learn more… 

Working with parameters is the most recommended option, because it avoids remembering all settings 

required to generate an image and thus can be easily retrieved for further work with it in a future. 
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EXPORT AND IMPORT PARAMETERS 

FFE allows sharing fractals through a function which exports all its parameters and configurations. This 

info can be employed by any FFE user in order to get the same fractal. 

• EXPORT PARAMETERS 

Click on “Export parameters” in “File” menu or press “Control + E”. Check that the image which 

parameters you want to export shows up in the form that opens, and select one of the following 

options: 

1. Include palette and pattern: if the image uses a palette or a pattern not built in FFE, it is 

recommended to apply this option. A dialog box will be opened when pressing the button 

in order to select the path to export the file of parameters. 

2. Only parameters: this option is designed to export the parameters of the images that use 

a built-in palette and pattern. The parameters will be exported to Windows’ clipboard 

when pressing the button. 

 

The exported parameters can be attached to an email and be sent to another FFE user. For instance, 

the parameters of the image above are the following: 
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• IMPORT PARAMETERS 

Click on “Import parameters” in “File” menu or press “Control + I”. With the form that opens you 

can import the parameters using two ways: 

1. Click on “Examine” so that a dialog box would be opened, and you can search the file of the 

exported parameters. 

 

2. Enter the line of the parameters in the text area and click on “Import”. 

 

CFp4WH9WI0dp15myUXi4HsXZm9J/YodItz2wb9LqOKAHH2oMXxOTteK9ffgNl/QVtKeg7SeR9FVu92SbDGmP7Ip1BkIw2n8jGeAU

nyLfRiMj3f5NC03aVzavFpwS92sBEtYv/0YjXXuz4Xc873GO8/3WaYBiCMmpbdbrKsPBf0OLZ1JsNbvsvwMw1k67t0WdmtkskFV7lpr

v+hZEuxloDtfSvxN1cz7y4S1DSSzAgY9Nz3/abNg6wZPM1zaSh6pho4w4K9gFgP0hjMiKhkNcsO0FHpP1zSwYU2A6wIXsEU1FhQ2tY

XuZ/khK7C1rwJOPVt5OVFpbokzKaQ3g9Eg3hUvrGLsoWYv7cP6/+QsXUXfg7NmYMTl5HHWXzrM1INyJfCF7jEh3SXtW7dekMssuj5

oGLeAg2vZRKi/GecPq0JCBQhMGmOweRSR1PI4JxY6eXM/5jMe1q5edd1XmUPMXKD75pt8XNSXLJ0nP8X38TKJbQlT0hFNAXB01y

PmewFHQLVGEIduL3h8LcsI/VFkWW61b542KmqGhf4H8drEkLIpHsfAskXZxK+DvHRp2G0kytdjVV/DDbklUY5g2MSigvsCg9CfC8gp

bDPmJWn2BBd2EfD4amw7e7ErhWJfmCRwbnlavRuC26GPXJSPeYTT8cXUjud6vAS9pEQCnS4W2hcWIOVXTJcsy9mJDzw1SmXZbq

7oFUB0XJNJmqpEFE3xHqQkMgcAGgJL+HNkq/x0EJBJaFW6QcODd2yPmtTGUo4+OyXj58LiZAN453egAGmxiYhwBuIozyLqRYoEfFg

8DX0v/ERr15x5G4SBDY/2mAGtwA4wl08hWTmoEMXoO3xLU3uXon9j5rI12ajvigM9X2VzgbEXHRBUFZAUguIRiJyqxKq1nRNEQzp

K9UsoonxjbEV4+rfjwVf2tqCsFdNtd9o/7WEVEvTHpujKGMIljLCDiSe7SJIHEzScjO48FVKsEQ677HruVIfrBIqzctBV0G/jGhmSBn/C19Y

Wn9EYR3qxTWMC/PHabke01KdHXU/vYzEfTC8gNg/6lRHEIWUzIO/ylTxgyRr98+K3/d48CfaokKQ9t8NOnRnUkAyzZpZanKIbkryYF

wqqLMxm18isThZxJs+TKSdIdi1UqyLExs9PNNJ81lEPw9KRbIWEEVamWRHM7Co4TU2bxn4zanM4QGdjsdJGjTJ7ap0Yvo+bUmXg+

VxS2pEBeCaHX69MgZLJB0nSD98pLa00LocDgpEcvdEAbiKPFtF92Tt2O9ODDfLTPX8uf/PWeUdf9Ng3bxcvDQW/hNftlLLTx6dMXk3k

vxyupO/XOGPElaegvw6S54oIu3bEcaxg3F8FzITroasJMOHuMUB/TAz3KPjhSIIDRq/VDuqUOosLqCwJfImf7shN2nfIKCskyoaejcMJ/

AaeVPRkC8GQfKUiXmfh76wjg181xRu0ZeWf8KphJaE6xhQqJbvKrVvF0NcdvTpZQb1eAS1uZI5L5cSaliU0jOG0Q63ijmHN3C6jMgw

BXtoBD+HF68XTlGRmjS6Eu9DPIbMaIzkks05k5wiemH+iq77uTS2RuKgCWrCokbpC6eU6Dm3H4X4A2k0dqO0M6beI/8rcDVuXp/Q

cch7ya2vLUaJ+8T3El/NsrOaGfKIbL8msBcXe0H4pFfK52UlNL/OuNnaHxnKjpy15C3FprF6F7UitQx5q+j5k/ss3DsAFt+PotPeIPvfhrPiJ

12FfCJo5J77pWEIdaq9dU/URXkv9OOEi1Q+UrZ33RrYiRxvroK/wp6c4napSPafsvyYH4nL7A+DewerxaQ3uto/DixUSlYWaPzKFh4B+

EVQKhSCAwcdsUOXVoa38llwU5FyNlcwnItAUXVtsLIAnbkJLFt532jK1pDTwk10mu5IK9Oqs0NqNgLsdm0n0cGbJOD2OKW8GzVtI1

oGr47sSra7F/sr6J3zQZLyY73x2fUwfRcpzG5U8ZKb8nkLPtGmD4/sm8d6QPHS+KPXBavbnZ2wI+6+LpKDeUATOFvZh7G2ixYkVDK2

eAOcBf0Ag/wdaPp6K2wqAnfPt6tQ22ViMEOs6oWjq6+XzqO7UPalmS58= 
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The corresponding image will be calculated in a new canvas. 

Learn more… 

Be aware that, when exporting with the option “Only parameters”, the previous content in Windows’ 

clipboard is lost, thus it is replaced with the parameters. 

Parameters files can also be imported by dragging and dropping them in the FFE working area. 

 

VIEW THE JULIA SETS OF A FRACTAL 

Open the “Julia viewer” from the “View” menu or press “Control + Alt + J”. If the “Active canvas” is 

compatible, this viewer shows the Julia sets that composes the fractal. 

* The “Julia viewer” is only compatible with fractals based on “Mandelbrot’s method”, excluding the special 

fractals.  

To view the Julia sets, move your mouse over the canvas. 

 

In order to calculate the Julia set that is showed in the viewer press “J” key and click over the canvas without 

moving the mouse. 

Learn more… 

Mandelbrot’s drawing method represents a map of all possible Julia sets.  Corresponding Julia sets to inner 

Mandelbrot are closed, while corresponding to outer Mandelbrot are opened. 
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APPLY JULITER TRANSFORMATIONS 

Open the “Juliter viewer” from the “View” menu or press “Control + Alt + U”. If the “Active canvas” is 

compatible, this viewer shows the possible transformations of the fractal. 

* The “Juliter viewer” is only compatible with fractals based on “Mandelbrot’s method”, excluding the 

special fractals.  

To view the possible Juliter Transformations, adjust the iteration number in the bottom bar and move your 

mouse over the canvas. 

 

In order to apply the transformation that is showed in the viewer press “U” key and click over the canvas 

without moving the mouse. 

In order to apply the transformation that is showed in the viewer without losing the exploring coordinates, 

press “L” key and click over the canvas without moving the mouse. 

Learn more… 

The “Juliter Transformation” arises during the development of new functionalities for FFE, and as a test of 

the hypothesis that fractals can be represented with an adjustable mixture between the Mandelbrot and 

Julia methods. More information here. 

 

AUTOMATE PROCESSES WITH TASKS 

* Tasks are not available for the special fractals. 

Open the tool “Tasks” from the “View” menu or press “Control + Alt + T”. This tool has a tab page per task 

with the adjusting controls for its parameters and a common area for all tasks that allows to fix the precision 

of the adjusting controls (zone1 in the image).  

https://www.fractalfun.es/juliter.php?i=en
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FFE 13.1 version includes the following tasks: 

• ITERATE: it increases or decreases the iterations number. 

• ZOOM: it performs a progressive zoom, positive or negative. 

• ROTATE: it increases or decreases the image rotation angle. 

• PALETTE SCROLLING: it scrolls the colours of the palette. 

• EXPONENT: it increases or decreases the exponent of the variable “Z”. 

• INITIAL Z: it increases or decreases the initial value of the variable “Z”. 

• CENTER: it scrolls the fractal horizontally and vertically. 

• JULIA: it modifies the “Real” and “Imaginary” components of Julia’s constant “C”. 

• DISTORTION: it modifies the “Real” and “Imaginary” components of Distortion constant “D”. 

1 
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• RELAXATION: it modifies the “Real” and “Imaginary” components of Relaxation constant “R”. 

• ORBIT TRAP OPACITY: it increases or decreases the opacity of the orbit trap. 

• ORBIT TRAP SIZE: it increases or decreases the size of the orbit trap. 

• ORBIT TRAP SCROLLING: it scrolls the orbit trap. 

Not all tasks are supported with all fractals, thus some of them are shown as “disabled” depending on 

“Active canvas”.  

Click on the “Start” button in order to associate the task tool to the “Active canvas”. Then, adjust the 

parameters and check the boxes of the tasks you would like to perform. This will modify progressively the 

parameters and will calculate a new image of the fractal every time. 

Uncheck the box of a task if you would like to stop it, and then, click on “Stop” button when you wish to 

disassociate the canvas. 

Learn more… 

The “Tasks” tool can only associate to one canvas every time (all exploring functions relay disabled during 

the association). 

A task can stop itself if any of the parameters reaches invalid values with the type of fractal loaded in the 

canvas. 

The “Decimal” adjust allows to select the decimal position that will vary in the parameter value when it is 

modified through its own adjusting control (it only works over tasks highlighted in blue). 

A task can be used combined with the option “Save image changes automatically” of the “Options” form in 

order to get images, like movie frames, for building a video or animation using an external application. 
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VIEW INFORMATION ABOUT THE FRACTAL 

Open the tool “Information” from “View” menu or press “Control + Alt + I”. This tool shows up information 

concerning the “Active canvas”. 

   

The available information is the following: 

• COORDINATES: VISIBLE AREA 

It shows the coordinates of the area of the fractal represented in the image. 

• COORDINATES: CENTRAL POINT 

It shows the coordinates of the point of the fractal corresponding to the centre of the image. 

• COORDINATES: MOUSE POINTER 

It shows the coordinates of the point of the fractal corresponding to the pointer location. 

• DIMENSIONS: FULL SET 

It shows the approximate diameter that the full fractal should have to view the selected area. It 

also compares this value with the size of a real object. 
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• DIMENSIONS: VISIBLE AREA 

It shows the approximated diameter of the fractal area being viewed. It also compares this value 

with the size of a real object. 

• DIMENSIONS: IMAGE 

It shows the printing dimensions of the image and its aspect-ratio. 

• ZOOM LIMIT 

It shows the zoom level of the “Active canvas” in a progress bar. It is located over a background 

that changes its colour in relation to three zoom levels: low (green), medium (amber) and high 

(red). 

• GENERAL INFORMATION 

It shows the type of fractal, the identifier number of its window and its comment. 

You can also view the formula used during the drawing of the “Active canvas”. To do this, open the 

“Formulas viewer” from the “View” menu or press “Control + Alt + R”. 

 

Learn more… 

The window identifier allows you to locate the subfolder corresponding to the canvas within the images 

folder. 
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HIBERNATION OF PROCESSES 

Another important feature of FFE is that it allows closing the application at any time without losing the 

calculations made for the pending images. The next time you start the application it will display a message 

offering the possibility to view the hibernations to resume the calculations from the point they stayed by. 

To do this, choose the hibernation you wish and click on the button “Continue”. The hibernations are 

available in the “Hibernations” tab of the form “File” that opens from the “View” menu or pressing “Control 

+ Alt + F”. 

 

Learn more… 

The calculation of certain images can be a slow process according to the fractal characteristics, the image 

size or the “Anti-aliasing filter" applied. In occasions like these you may need to close the application and it 

is then when the hibernation of calculation avoids losing the work previously done. 

 

RENDER FRACTALS IN HIGH RESOLUTION 

* The renderer is not available for special fractals of the Buddhabrot and Attractor types. 

“Anti-aliasing” is a method that allows obtaining higher quality images, closest to the fractal, using 

additional colouring operations. FFE allows rendering fractals up to the following limits given by the chosen 

antialias filter grid: 
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Anti-aliasing Maximum resolution Description 

1x1 256 Mpx Low quality and high speed (without anti-aliasing) 

2x2 128 Mpx Medium quality and high speed 

3x3 85 Mpx High quality and medium speed 

4x4 64 Mpx Very high quality and low speed 

 

Open the “Renderer” from the “View” menu or press “Ctrl + Alt + N”. 

 

Adjust the general rendering options: 

• SIZE: Render output size. 

• ANTI-ALIAS FILTER: Anti-aliasing filter level. 

To finish, press the “Start” button and when the process is complete, save the final image. 
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RENDERING LAGRANGIAN DESCRIPTORS 

* Discrete Lagrangian Descriptor (DLD) is not available for special fractals of the IFS, Buddhabrot and 

Attractor types. 

“Anti-aliasing” is a method that allows obtaining higher quality images, closest to the fractal, using 

additional colouring operations. FFE allows rendering fractals up to the following limits given by the chosen 

antialias filter grid: 

Anti-aliasing Maximum resolution Description 

1x1 256 Mpx Low quality and high speed (without anti-aliasing) 

2x2 128 Mpx Medium quality and high speed 

3x3 85 Mpx High quality and medium speed 

4x4 64 Mpx Very high quality and low speed 

 

Open the “DLD Renderer” from the “View” menu or press “Alt + G”. 
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Adjust the general rendering options: 

• SIZE: Render output size. 

• ANTI-ALIASING FILTER: anti-aliasing filter level. 

• USE THE CANVAS PALETTE: uses the original palette of the canvas. 

• BASE COLOUR: the base colour to be used, if the canvas palette is not used. 

• STRUCTURE COLOUR: the colour to be used to draw the structures, if the canvas palette is not used. 

Adjust the DLD algorithm options: 

• ESCAPE MAGNITUDE: choose whether to use a custom value or not use it and have the algorithm 

use the canvas's escape conditions. 
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• P-NORM: choose an exponent P to determine the geometry of the space in which the algorithm 

will measure distances. 

To finish, press the “Start” button and when the process is complete, save the final image. 

Learn more... 

Lagrangian Descriptors (LD) are a tool used in the analysis of Fluid Dynamics, particularly useful for 

understanding the transport and mixing of particles in complex systems. In oceanography, for example, 

they are employed to study currents or the transport of nutrients and pollution, making it possible to 

identify hidden dynamical structures in flows. 

 

CREATING STEREOGRAPHIC PROJECTIONS 

* The Stereographic projection is not available for the special fractals Bifurcation, IFS, Buddhabrot and 

Attractor. 

To draw the projection, FFE locates a Riemann Sphere on the fractal and then calculates how it is reflected 

on its surface. 

Open the “Riemann Sphere” designer from the menu “View” or pressing “Alt + R”. The sphere previews will 

be drawn automatically if the “Active canvas” is compatible.  

 

1 

2 
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Adjust the general options: “Background” colour, “View” type, and output “Size”. Then, select one of the 

following processes: 

• GENERATE IMAGES (zone 1 in the image) 

This process generates an image with the set of selected views, and one independent image per 

each of them. To do this, check the views you wish and then press the button “Start”. The images 

can be saved when the process finishes.  

• GENERATE SEQUENCE (zone 2 in the image) 

This process generates a sequence of images of the spheres’ elevation (central preview). To do this, 

set the following parameters: 

1. Initial illumination: start location of the light focus. 

2. Focus spins: number of spins that give the focus and the direction. 

3. Sphere spins: number of spins that give the sphere and the direction. 

4. Length: length in seconds of the sequence. 

5. FPS: number of frames per second. 

6. Hologram: it creates special frames to be used with a holographic pyramid. 

Then press the button “Start”. While the process is running, the frames will be saved in the images 

folder of the application, inside a specific subfolder for the process. You will be able to open the 

images’ folder when the process is finished. 

 

CREATING MAPS OF JULIA 

* Maps of Julia are not available for special fractals and are only compatibles with fractals based on 

“Mandelbrot’s method”. 

Open the “Julia maps” designer from the menu “View” or pressing “Alt + M”. 
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The box “Fit Julias” centres and fits in its cell every Julia set. 

Adjust the number of cells and press “Start”. Save the resultant image once the process ends. 

Learn more... 

Julia maps are made of Julia sets ordered suitably so a map equivalent to a graphic obtained with 

“Mandelbrot’s method” is shown. 
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CREATING KALEIDOSCOPIC IMAGES 

Open the Kaleidoscopes designer from the menu “View” or pressing “Alt + K”. 

 

This designer has an area that allows to customize the triangle that is taken as a pattern to draw the 

kaleidoscopic image, and another one that allows to customize the final image (zones 1 and 2 respectively).  

Choose “Fractal” in order to create a kaleidoscopic image from the “Active canvas” or choose the option 

“Image” to import an external image. 

In order to customize the triangular pattern: 

• Modify its size with the adjust control “Size”. 

• Modify its position with the left button of your mouse over the preview. 

In order to customize the final image: 

1 

2 

3 
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• You can apply the “Tube” effect with the wished colour. 

• You can show the triangular “Divisions” with the wished colour. 

Finally, choose the aspect ratio and the size you want for the final image (zone 3 of the image) and then 

click on the button “Save image”. 

The button “Save texture” allows saving the basic image that serves to fill in the areas of any size. 

 

CREATING PYTHAGORAS TREE 

Open the Pythagoras designer from the “View” menu or press “Alt + P”. 

 

To set the drawing algorithm: 

• Adjust the iterations number. A bigger number of iterations will produce more branches. 

• Adjust the value of the variable angles of the right triangle. This causes the tree to tilt to one side 

or the other. 
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• Adjust the trunk height. Its maximum value will depend of the size of the tree. 

• Adjust the size of the tree. 

• Activate the “Zigzag” mode to create a pointy tree or inactivate it to create a rounded tree. 

To customize the image, choose the colours you want for the inside and outside zones of the fractal.  

Finally, choose the size you want for the final image and then click on the button “Save image”. 

 

CREATING SIERPINSKI DESIGNS 

Open the Sierpinski designer from the “View” menu or press “Alt + S”. 

 

In order to set the algorithm, adjust the iterations number and select an available drawing mode: “Triangle” 

or “Carpet”. 

To customize the image, choose the colours you want for the inside and outside zones of the fractal.  

Finally, choose the size you want for the final image and then click on the button “Save image”. 
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CREATING DIFFUSION-LIMITED AGGREGATIONS 

The aggregate is achieved by a particles liberation that takes random paths until they collide with something 

that stops them. FFE allows to set a seed in order to make the aggregate grow around it. 

Open the aggregation designer from the “View” menu or press “Alt + A”. 

 

In order to set the aggregate process: 

• Choose the option “Image” in order to import an external image as seed. Then, you can change its 

position with the left button of your mouse over the preview. 

• Modify its size with the adjust control “Size”. 

• Select an available colouring method in the combo box “Method”. 

1. BORDER: it colours the image according to the distance between the particle and the 

canvas borders. 

2. SEED: it colours the image according to the distance between the particle and the seed 

borders. 

3. MIX: this is a mix between the two previous colouring types. 

1 
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• Select an available palette in the combo box “Palette”. 

• Choose the aspect ratio and the size you want for the final image (zone 1 of the image). The process 

may take some time depending on the selected size, but the “Aggregates designer” can be closed 

without interrupting itself. 

Then, choose DLA or Eden mode and press the “Start” button in order to start the process. It will end by 

itself when all the canvas edges are closed and no more particles can access, but the background colour can 

be selected and the image can be saved at any time. To do this, check the box “Background”, select the 

colour and then press the button “Save image”. 

 

CREATE SNOWFLAKES 

FFE is inspired by the symmetry of the hexagonal crystalline system of ice crystals in order to create 

snowflakes. 

Open the “Snowflakes” designer from the “View” menu or by pressing “Alt + N”. 
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To create the snowflake, use the design area on the left, where you can execute the following actions: 

• ACTIVATE A BRANCH 

Click on one end of the branch. The ends of the activated branch will be colored black to identify it. 

• ADD A PRIMARY BRANCH 

Click the left mouse button on an empty area. The parent branch will be shown in blue. 

• ADD A SECONDARY BRANCH 

Right-click on an empty area. The child branch will be displayed in red. 

• MOVE ONE BRANCH END 

With the left mouse button, click on the desired end of a branch and, without releasing it, move 

the mouse. Release the button to confirm scrolling. 

• DELETE A BRANCH 

Double-click one of the ends of the branch. If the endpoint belongs to a child branch, only this 

branch will be deleted. If the endpoint belongs to a parent branch, this and all its child branches 

will be deleted. 

• DELETE ALL BRANCHES 

Click the middle mouse button anywhere in the design area. 

The gray area of the design area is indicative and helps to create patterns that, when replicated with 

hexagonal symmetry, do not produce unexpected branch crossings. 

To personalize the image, choose the thickness of the line and the colors you want inside and outside the 

snowflake. 

Finally, choose the size at which you want to generate the final image and press the "Save image" button. 

 

CREATING CELLULAR NOISE 

To create cellular noise, FFE locates randomly a set of points which are known as “Cells” and then applies 

the “Voronoi Diagram” to the set to colouring the plane. 

Open the Cellular Noise designer from the menu “View” or pressing “Alt + C”. 
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In order to set the drawing process: 

• Choose one of the available cell distribution modes: random, beehive or grid. 

• Choose the number of cells you want to use. 

• Adjust the distance of reference for the calculation. The value 1 is the distance to the farthest cell 

and the polygons will be drawn with more definition. 

• Choose one of the colouring methods available: 

1. To use a single colour, check the box “Colour” and select it. 

2. To use a palette, uncheck the box mentioned in the previous point and then select a palette 

in the combo box. 

Finally, choose the aspect ratio and the size you wish to the final image (zone 1 in the image) and then press 

the button “Start”. 

At any time, during calculation and once completed, the colours may be inverted. To do this, press the 

button “Invert”. 

The images can be saved when the process finishes. 

 

1 
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CREATING MULTIPLICATION DIAGRAMS 

Open the Diagrams Designer from the “View” menu or press “Alt + D”. 

 

To set the drawing algorithm: 

• Set the “Multiplier” number. 

• Set the “Number of operations”. 

All numbers from zero to the number of operations will be multiplied by the multiplier and such results 

will be represented with lines in the diagram. 

In order to apply the parameters, once you have introduced the values, press “Enter” or the button 

“Apply”. It can also be varied, to do so adjust the increments and check the boxes placed on the right 

of each parameter. 

To customize the image: 

• Choose the colour for the “Outside”. This will colour the outer part of the circumference. 

• Choose a colour for the “Inside”. This will colour the inside of the circumference. 
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• Choose the colour for the “Marks”. This colour will draw the circumference’s perimeter and the 

corresponding points to the number of operations. 

• Choose one of the available colouring methods for the lines: 

1. Colour. Use always the same colour for all the lines in the diagram. 

2. Palette. Use the different colours in a palette in order to differentiate the lines of the 

diagram according to one of the following methods: 

a. Product. The line's colour will depend on the products' result. 

b. Multiplier. The line's colour will depend on the multiplying number. 

Finally, choose the size you want for the final image and then click on the button “Save image”. 

 

CREATE BOIDS NETWORKS 

FFE allows you to create Boids Networks based on the Reynolds Model to observe emergent behaviours. 

Open the "Boids Networks" designer from the "View" menu or by pressing "Alt + B". 

 

To customize the simulation, use the following control groups: 

• SIMULATION 

With this control group, you can choose the type of simulation you want. 

1. Water: boids will be represented in the form of fish. 

2. Air: boids will be represented in the form of birds. 

3. Land: boids will be represented in the form of ants. 

4. Machine: boids will be represented in the form of circles. 
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When positioning the mouse over the preview, informative text will appear with the parameter 

values associated with the chosen simulation type. 

 

• RULES 

This control group allows you to activate or deactivate the basic rules defined by the Reynolds 

Model. 

1. Separation: boids use this rule to try to avoid colliding with each other. 

2. Alignment: boids use this rule to try to match the speed and trajectory of those around 

them. 

3. Cohesion: boids use this rule to try to belong to a group. 

Additionally, for "Air" and "Earth" simulations, a special rule specific to FFE will be available. 

1. Migration (air): this rule simulates the behaviour of migratory birds. When activated, under 

suitable conditions, "V"-shaped structures may appear, with a leading boid guiding the rest. 

2. Inspection (earth): this rule simulates the behaviour of ants inspecting their environment 

for food. 

• CURSOR 

This control group allows you to decide the type of reaction boids will have when encountering the 

mouse cursor. 

1. Disabled: boids will not react to the cursor. 

2. Interest: boids will show interest in the cursor and deviate from their original trajectory to 

move towards it. 

3. Obstacle: boids will try to avoid the cursor while maintaining their original trajectory as 

much as possible. 

4. Panic: boids will feel panic from the cursor and deviate from their original trajectory to flee 

from it. 

Use the "Size" control to adjust the cursor size. 

• TURBULENCE 

This control group allows you to activate an FFE-specific algorithm simulating random turbulence 

affecting the trajectory and speed of the boids. 

1. Smooth: turbulence will have a gentle effect on the movement of the boids. 

2. Strong: turbulence will have a strong effect on the movement of the boids. 

When the "Show" checkbox is activated, a "wind vane" will appear, representing the speed and 

direction of the turbulence at each moment. 
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• PREY 

This control group allows you to add or remove boids of the "prey" type, as well as adjust the 

parameters of the field of vision and vision range. 

• PREDATORS 

This control group allows you to add or remove boids of the "predator" type, as well as adjust the 

parameters of the field of vision and vision range. 

When the "Initiate Attack" checkbox is activated, “predator” boids will attack “prey” boids, 

eliminating the latter if caught. 

• AREA 

This control group allows you to activate or deactivate the boundaries of the area in which the 

boids move. 

 

When the boundaries are deactivated, boids that exceed the window boundaries on any side 

reappear on the opposite side. 

The "Clear" button removes all boids. 

• GENERAL 

This control group allows you to adjust the following general parameters of the simulation. 

1. Size: Adjusts the size of the boids. “Predator” boids will be 1.5 times larger than “prey” 

boids. 

2. Speed: Increases or decreases the speed of the boids. When the "Initiate Attack" checkbox 

is activated, the speed of “predator” boids will be slightly higher than that of “prey” boids. 

Press the "Start" button to begin the simulation or "Stop" to pause it. The "Reset" button restores all 

parameters to their initial values.  

Learn more... 

Deleted boids will not disappear automatically; they will be marked to leave the area when possible. 
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CREATING LINEAR FRACTALS 

FFE allows to create linear fractals from a pattern formed by lines that connect a group of points defined 

by the user. This is possible by replicating the whole pattern and adjusting its scale so it fits within each 

segment from the original pattern, and so on with each iteration. 

Open the “Linear Fractals” designer form the menu “View” or pressing “Alt + L”. It works in full screen, so 

FFE will maximize and the menu “Linear” will show up in order to access all the designer’s functions. 

 

Here you can find the different available functions: 

• LOAD A BUILT-IN PATTERN 

It allows to load the sample patterns included in the software under the different categories that 

show in the submenu when click. 

• ADD POINT “X” OF 8 

It allows to add points till a maximum of 8. Each new point will show up in the middle of the drawing 

area, and then you will be able to change its position by using the mouse. To do so, place the pointer 

over a point and click with the left button upon it when the icon changes to a hand, slide and release 

the button to confirm the movement. You can also add points by clicking upon anyplace on the 

drawing area where another former point does not exist. 

• DELETE ONE POINT OF “X” 

It allows to eliminate the last point added. However, any existing point in the drawing area can be 

erased by clicking upon it. 

• SHOW GRID 
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It allows to show up and hide the grid. The background colour will be hidden behind it when the 

grid is visible. 

• SNAP POINTS TO GRID 

This option sets the points in the grid when changing their position with the mouse. 

• DRAW ALL ITERATIONS 

The lines corresponding to each iteration in the fractal will show up when checking this option, and 

palettes could be used to colour it in. 

When unchecked, the only line showing up will be the last one. This means that the fractal image 

will be one line coloured with only one colour. 

• INVERT 

This option causes the fractal to generate inversely. 

• COLOUR THE BACKGROUND IN… 

It allows to choose a predefined or customized colour for the background. This background colour 

will not be visible when the grid is. 

• COLOUR THE LINES IN… 

It allows to choose a predefined or customized colour for the lines of a fractal. 

• COLOUR THE ITERATIONS WITH THE PALETTE… 

This option will only be available when checking the box “Draw all then iterations”, and it allows to 

use palettes to colour the different levels of iteration in the fractal. 

• CALCULATE THE IMAGE 

When the pattern has at least three points, this command will allow to force the calculus of a fractal 

image. It can also be done by clicking the right button of the mouse upon any point in the drawing 

area. Nonetheless, the image calculus will always be produced automatically after 5 seconds after 

any modification with the parameters. 

• STOP THE CALCULATION 

When the image is in calculating progress, this command allows to interrupt it. It also can be done 

pressing “Esc”. 

• CLEAR THE DRAWING AREA 

This command allows to eliminate any pattern or fractal image in the drawing area. It can also be 

done by clicking with the middle button of the mouse anywhere in the drawing area. 

• CALCULATE THE FRACTAL DIMENSION (square box) 

It calculates the fractal dimension using the Minkowski-Bouligand box-counting method. It will only 

be available when the “Draw all iterations” option is not being used. 

• CALCULATE THE FRACTAL DIMENSION (aspect ratio) 
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It calculates the fractal dimension using a variant of the Minkowski-Bouligand box-counting method 

that uses box dimensions proportional to the image dimensions. It will only be available when the 

“Draw all iterations” option is not being used. 

• SAVE IMAGE 

This command allows to save the different graphic components in image format, under the selected 

option in the submenu that shows when clicking. For example, a fractal and its background can be 

saved by clicking in the submenu “Background + fractal”. 

 

 

CREATING CELLULAR AUTOMATON 

FFE allows to create cellular automaton based on the Game of Life or rules. 

Open the “Cellular Automaton” designer from the “View” menu or by pressing “Alt + U”. This works in full 

screen mode, so FFE will be maximized to improve the experience, and the “Automaton” menu will be 

displayed to give access to all the designer functions. 
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The different functions available in the “Automaton” menu are described below: 

• MODE 

It allows switching between the “Life”, “Rule” and the “Multistate” mode, as well as establishing an 

initial layout of active cells in the automaton or changing the number of the rule in that mode. It 

must be considered that for the “Ruler” mode, only the state of the first row of the grid can be 

modified. 

To manually activate or deactivate cells, click on the desired cells. You can also activate several cells 

in a row by clicking and, without releasing the button, moving the mouse. In the same way, but also 

pressing the "Shift" key, several cells can be deactivated in a row. 

• CELL SIZE 

It allows changing the size of the cell, so that for a larger size the number of cells that will make up 

the grid will be smaller, and the automaton will work at a higher speed. 

• CELL SHAPE 

Allows you to change the shape of the cell between “Square” and “Round”. 

• COLOUR THE GRID IN… 

Allows you to choose a predefined or customized colour for the grid lines. 

• COLOUR THE BACKGROUND IN… 

Allows you to choose a predefined or customized colour for the background of the grid. 

• COLOUR LIVING CELL IN… 

Allows you to choose a predefined or customized colour to represent a living cell. 

• COLOUR TRAIL IN… 

Allows you to colour the trail left by a cell with a single predefined or customized colour. The colour 

of the cell will darken over time. 

• COLOUR TRAIL WITH THE PALLETTE… 

Allows you to colour the trail left by a cell with the colours of a palette. The cell colour will go 

through the different colours in the palette over time. 

• START 

It starts the cellular automaton. It can also be started by clicking the right mouse button. 

• STOP 

When the cellular automaton is running, this command allows you to stop it. It can also be stopped 

by pressing the "Escape" key on the keyboard. 
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• CLEAR 

This command allows you to remove all cells from the grid. They can also be removed by clicking 

the middle mouse button anywhere on the grid. 

• SAVE IMAGE 

This command allows you to save the current state of the cellular automaton in image format. 

• SAVE IMAGE CHANGES AUTOMATICALLY 

This command allows you to save in image format any changes that occur in the cellular automaton 

during its operation. 

 

Learn more… 

When a cellular automaton relies on the state of cells in one line to generate the state of the next, as in 

"Rule" mode, it is said to be a one-dimensional automaton. Instead, when based on the state of cells 

throughout the plane, as in Conway's Game of Life, it is said to be a two-dimensional automaton. In two-

dimensional cellular automaton, the plane extends infinitely in all directions, but in FFE it has been decided 

to use a toroidally folded plane, so that complex structures that exceed the limits of the window on any of 

its sides appear by the opposite side. 

 

CREATING MAZES 

FFE allows you to create random mazes based on the DFS (Depth-First Search) algorithm. 

Open the “Maze” Designer from the “View” menu or by pressing “Alt + G”. This works in full screen mode, 

so FFE will be maximized to improve the experience, and the “Mazes” menu will be displayed to give access 

to all the designer functions. 
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The different functions available in the “Mazes” menu are described below: 

• NEW 

Generates a new random maze using a DFS (Depth-First Search) algorithm, using the current 

settings. 

• NEW WITH LOOPS 

Change the loop settings and generate a new random maze. Loops are created by removing a 

percentage of walls. 

• NEW WITH SIZE 

Change the size settings and generate a new random maze. 

• NEW WITH CORRIDOR WIDTH 

Change the corridor width settings and generate a new random maze. 

• SHOW EXIT PATH 

Displays the exit path of the current maze. 

• HIDE EXIT PATH 

Hides the exit path of the current maze. 

• SHOW EXIT ANIMATION 

Displays an animation of navigating the exit path of the current maze. 

• FIND EXIT 

Searches for the exit using a BFS (Breadth-First Search) algorithm, without knowing the exit path. 

• SAVE IMAGE 

This command allows you to save the current maze in image format. 
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Learn more… 

Depth-First Search (DFS) and Breadth-First Search (BFS) algorithms are used in video game design, artificial 

intelligence (to evaluate search and decision-making algorithms), and even in computational biology, where 

maze models are used to simulate the movement of molecules in obstacle-ridden environments. 
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ADVICES 

To make a good use of FFE you can get updated information and tips in www.fractalfun.es/en. 
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